package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`k7y6k0qmlx0f\..+?comp_company_rows_`)
var str = `k7y6k0qmlx0f.2hfzyz5bm6uck.comp_company_rows_1_37d26pw12t8g8_25_1.sql
k7y6k0qmlx0f.2od9tulaeeqs0.comp_company_rows_1_37d26pw12t8g8_25_2.sql
k7y6k0qmlx0f.2oq00v8k78cg0.comp_company_detail_reg_1.sql
k7y6k0qmlx0f.3cbn22h9crggk.comp_company_rows_1_37d26pw12t8g8_25_0.sql
k7y6k0qmlx0f.6lk9rcohc7w8.comp_company_rows_1_37d26pw12t8g8_25_3.sql`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}