const regex = /k7y6k0qmlx0f\..+?comp_company_rows_/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('k7y6k0qmlx0f\\..+?comp_company_rows_', 'g')
const str = `k7y6k0qmlx0f.2hfzyz5bm6uck.comp_company_rows_1_37d26pw12t8g8_25_1.sql
k7y6k0qmlx0f.2od9tulaeeqs0.comp_company_rows_1_37d26pw12t8g8_25_2.sql
k7y6k0qmlx0f.2oq00v8k78cg0.comp_company_detail_reg_1.sql
k7y6k0qmlx0f.3cbn22h9crggk.comp_company_rows_1_37d26pw12t8g8_25_0.sql
k7y6k0qmlx0f.6lk9rcohc7w8.comp_company_rows_1_37d26pw12t8g8_25_3.sql`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}