use strict;
my $str = 'k7y6k0qmlx0f.2hfzyz5bm6uck.comp_company_rows_1_37d26pw12t8g8_25_1.sql
k7y6k0qmlx0f.2od9tulaeeqs0.comp_company_rows_1_37d26pw12t8g8_25_2.sql
k7y6k0qmlx0f.2oq00v8k78cg0.comp_company_detail_reg_1.sql
k7y6k0qmlx0f.3cbn22h9crggk.comp_company_rows_1_37d26pw12t8g8_25_0.sql
k7y6k0qmlx0f.6lk9rcohc7w8.comp_company_rows_1_37d26pw12t8g8_25_3.sql';
my $regex = qr/k7y6k0qmlx0f\..+?comp_company_rows_/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}