# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\G([^_\d]*)\d/\1/gm;t' <<< "123-abc-123_abc-123_abc_123_abc"