use strict;
my $str = '123-abc-123_abc-123_abc_123_abc';
my $regex = qr/\G([^_\d]*)\d/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";