$re = '/\G([^_\d]*)\d/m';
$str = '123-abc-123_abc-123_abc_123_abc';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;