using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/servic[eo]s";
string input = @"localhost/servics/family
somedomain.com/services/something";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}