package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/servic[eo]s`)
var str = `localhost/servics/family
somedomain.com/services/something`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}