using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"^[a-zA-Z0-9_-]+=>[a-zA-Z0-9_-]+$";
        string input = @"Field=>Value-True
 =>False_name
Bad_name_2=>
 => 
=>";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}