re = /^[a-zA-Z0-9_-]+=>[a-zA-Z0-9_-]+$/m
str = 'Field=>Value-True
=>False_name
Bad_name_2=>
=>
=>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end