using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#[^\s]+|(?<=\s|^)@[^\s@#]+";
string input = @"@twittername blah blah blah #hashtag blah blah @twittername blah email@email.com blah blah #hashtag2 blah blah #h@shtag";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}