re = /#[^\s]+|(?<=\s|^)@[^\s@#]+/
str = '@twittername blah blah blah #hashtag blah blah @twittername blah email@email.com blah blah #hashtag2 blah blah #h@shtag'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end