# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(;)?(?:^| +)([\d.]+)[ A-Z\\/\d]+/$1$2/gm;t' <<< "2 MG/ML
500 MCG
100 MG ; 200 MG ; 200 MCG
100 MCG/ML
325 MG ; 37.5 MG
60 G ; 9 G/1000 ML"