import re
regex = re.compile(r"(;)?(?:^| +)([\d.]+)[ A-Z\/\d]+", flags=re.MULTILINE)
test_str = ("2 MG/ML\n"
"500 MCG\n"
"100 MG ; 200 MG ; 200 MCG\n"
"100 MCG/ML\n"
"325 MG ; 37.5 MG\n"
"60 G ; 9 G/1000 ML")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)