use strict;
my $str = '2 MG/ML
500 MCG
100 MG ; 200 MG ; 200 MCG
100 MCG/ML
325 MG ; 37.5 MG
60 G ; 9 G/1000 ML';
my $regex = qr`(;)?(?:^| +)([\d.]+)[ A-Z\/\d]+`mp;
my $subst = '$1$2';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";