#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?i)DATE\s*(?i)AUTHOR\s*(?i)DESCRIPTION\s*)()"
Local $sString = "/*********************************************************************************************** " & @CRLF & _
"PROCEDURE: DEL_ABCD_Table1 " & @CRLF & _
" " & @CRLF & _
"PARAMETERS: Sample int" & @CRLF & _
" " & @CRLF & _
"APPLICATION: ABCD" & @CRLF & _
"" & @CRLF & _
"PURPOSE: Deletes all records from the Table1" & @CRLF & _
"" & @CRLF & _
"NOTES: " & @CRLF & _
"" & @CRLF & _
"MODIFIED " & @CRLF & _
"DATE AUTHOR DESCRIPTION" & @CRLF & _
"---------- -------------- -------------------------------------------------------------" & @CRLF & _
"08/08/2012 Jim Initial Version" & @CRLF & _
"09/25/2014 Pam Adding Canvas" & @CRLF & _
"09/11/2018 Dwight Adding rootbeer " & @CRLF & _
"12/24/2019 Angela Adding Catnip" & @CRLF & _
"**********************************************************************************************/ "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")