import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?i)DATE\\s*(?i)AUTHOR\\s*(?i)DESCRIPTION\\s*)()";
final String string = "/*********************************************************************************************** \n"
+ "PROCEDURE: DEL_ABCD_Table1 \n"
+ " \n"
+ "PARAMETERS: Sample int\n"
+ " \n"
+ "APPLICATION: ABCD\n\n"
+ "PURPOSE: Deletes all records from the Table1\n\n"
+ "NOTES: \n\n"
+ "MODIFIED \n"
+ "DATE AUTHOR DESCRIPTION\n"
+ "---------- -------------- -------------------------------------------------------------\n"
+ "08/08/2012 Jim Initial Version\n"
+ "09/25/2014 Pam Adding Canvas\n"
+ "09/11/2018 Dwight Adding rootbeer \n"
+ "12/24/2019 Angela Adding Catnip\n"
+ "**********************************************************************************************/ ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}