# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?i)DATE\s*(?i)AUTHOR\s*(?i)DESCRIPTION\s*)()"
test_str = ("/*********************************************************************************************** \n"
"PROCEDURE: DEL_ABCD_Table1 \n"
" \n"
"PARAMETERS: Sample int\n"
" \n"
"APPLICATION: ABCD\n\n"
"PURPOSE: Deletes all records from the Table1\n\n"
"NOTES: \n\n"
"MODIFIED \n"
"DATE AUTHOR DESCRIPTION\n"
"---------- -------------- -------------------------------------------------------------\n"
"08/08/2012 Jim Initial Version\n"
"09/25/2014 Pam Adding Canvas\n"
"09/11/2018 Dwight Adding rootbeer \n"
"12/24/2019 Angela Adding Catnip\n"
"**********************************************************************************************/ ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.