using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[\s?]*)|(\s+$)";
string substitution = @"";
string input = @"??ABC?
? ?abc
?abc?
abc
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}