package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[\s?]*)|(\s+$)`)
var str = `??ABC?
? ?abc
?abc?
abc
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}