use strict;
my $str = '??ABC?
? ?abc
?abc?
abc
';
my $regex = qr/(^[\s?]*)|(\s+$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";