#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^\s*public\s+function\s+(?!__)\K\w+\b"
Local $sString = "class Dashboard extends MY_Controller {" & @CRLF & _
"" & @CRLF & _
" public function __construct()" & @CRLF & _
" {" & @CRLF & _
" parent::__construct();" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" public function index()" & @CRLF & _
" {" & @CRLF & _
" $this->has_access() ;" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")