const regex = /^\s*public\s+function\s+(?!__)\K\w+\b/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*public\\s+function\\s+(?!__)\\K\\w+\\b', 'img')
const str = `class Dashboard extends MY_Controller {
public function __construct()
{
parent::__construct();
}
public function index()
{
\$this->has_access() ;
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}