$re = '/^\s*public\s+function\s+(?!__)\K\w+\b/im';
$str = 'class Dashboard extends MY_Controller {
public function __construct()
{
parent::__construct();
}
public function index()
{
$this->has_access() ;
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);