$re = '/bar0(?![|])/m';
$str = '1) Search matches in the foobar0 - matches should be found
2) Search matches in the foobar0| - matches should be not found
3) Search matches in the foobar0|0 - matches should be not found
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);