re = /bar0(?![|])/m
str = '1) Search matches in the foobar0 - matches should be found
2) Search matches in the foobar0| - matches should be not found
3) Search matches in the foobar0|0 - matches should be not found
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end