// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<status_codes>(i|s|x|S|d|h|\*|\>|\s)+) *(?P<prefix>(?P<ip>[0-9\.\:\[\]]+)\/(?P<mask>\d+))? +(?P<next_hop>\S+) +(?P<number>[\d\.\s\{\}]+)(?: *(?P<origin_codes>(i|e|\?)))?$").unwrap();
let string = "s>i2001:718::2:99/128 195.113.156.4 0 100 0 i
s i 195.113.156.4 0 100 0 i
s>i2001:718::2:101/128
10.2.8.1 0 100 0 i
s i 10.2.8.1 0 100 0 i
s>i2001:718::2:116/128
195.113.156.9 1000 205 0 65086 i
s i 195.113.156.9 1000 205 0 65086 i
s i 2001:718:0:600:0:1a:1a:11
1000 110 0 65086 i
s>i2001:718:180a::/48 10.2.7.1 11 100 0 65091 ?
s i 10.2.7.1 11 100 0 65091 ?
s>i2001:718:180b::/48 10.2.7.1 18 100 0 65091 ?
s i 10.2.7.1 18 100 0 65091 ?
s>i2001:718:180c::/48 10.2.7.1 11 100 0 65091 ?
s i 10.2.7.1 11 100 0 65091 ?
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}