$re = '/src\/components\/picker/';
$str = 'src/components/picker
src/modules/page/components/picker';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);