re = /src\/components\/picker/
str = 'src/components/picker
src/modules/page/components/picker'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end