import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a?)?:\\w+:(\\d{18}>)?|(\\u00a9|\\u00ae|[\\u2000-\\u3300]|\\ud83c[\\ud000-\\udfff]|\\ud83d[\\ud000-\\udfff]|\\ud83e[\\ud000-\\udfff])";
final String string = "<:custom_emoji:652867697494720533>\n"
+ "<a:animated_custom_emoji:741032442814791702>\n"
+ ":smiley:\n"
+ "😀\n\n"
+ "Lorem Ipsum dolor sit amet...\n"
+ "123456789";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}