using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d+(?:\.\d+)+[^-\s.]*(?:-(?!(?:amd64|linux)\b)[^-\s.]*)*";
string input = @"amazon-agent-helpdesk-1.0.10.tgz > 1.0.10
gk2-utils-1.0.0-1065298.tgz > 1.0.0-1065298
1.0.10 > 1.0.10
1.0.10-amd64-21736 > 1.0.10
1.0.10-linux-21736 > 1.0.10
1.0.20-SNAPSHOT-1359033 > 1.0.20-SNAPSHOT-1359033
1.0.20-SNAPSHOT-1359033-amd64-11240 > 1.0.20-SNAPSHOT-1359033
1.0.10 > 1.0.10
1.0.10-amd64-21736 > 1.0.10
1.0.10-amd64-21736-linux-amd64 > 1.0.10
1.0.10-linux-21736 > 1.0.10
1.0.20-SNAPSHOT-1359033 > 1.0.20-SNAPSHOT-1359033
1.0.20-SNAPSHOT-1359033-amd64-11240 > 1.0.20-SNAPSHOT-1359033";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}