import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d+(?:\\.\\d+)+[^-\\s.]*(?:-(?!(?:amd64|linux)\\b)[^-\\s.]*)*";
final String string = "amazon-agent-helpdesk-1.0.10.tgz > 1.0.10\n"
+ "gk2-utils-1.0.0-1065298.tgz > 1.0.0-1065298\n"
+ "1.0.10 > 1.0.10\n"
+ "1.0.10-amd64-21736 > 1.0.10\n"
+ "1.0.10-linux-21736 > 1.0.10\n"
+ "1.0.20-SNAPSHOT-1359033 > 1.0.20-SNAPSHOT-1359033\n"
+ "1.0.20-SNAPSHOT-1359033-amd64-11240 > 1.0.20-SNAPSHOT-1359033\n\n\n"
+ "1.0.10 > 1.0.10\n"
+ "1.0.10-amd64-21736 > 1.0.10\n"
+ "1.0.10-amd64-21736-linux-amd64 > 1.0.10\n"
+ "1.0.10-linux-21736 > 1.0.10\n"
+ "1.0.20-SNAPSHOT-1359033 > 1.0.20-SNAPSHOT-1359033\n"
+ "1.0.20-SNAPSHOT-1359033-amd64-11240 > 1.0.20-SNAPSHOT-1359033";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}