$re = '/\b\d+(?:\.\d+)+[^-\s.]*(?:-(?!(?:amd64|linux)\b)[^-\s.]*)*/m';
$str = 'amazon-agent-helpdesk-1.0.10.tgz > 1.0.10
gk2-utils-1.0.0-1065298.tgz > 1.0.0-1065298
1.0.10 > 1.0.10
1.0.10-amd64-21736 > 1.0.10
1.0.10-linux-21736 > 1.0.10
1.0.20-SNAPSHOT-1359033 > 1.0.20-SNAPSHOT-1359033
1.0.20-SNAPSHOT-1359033-amd64-11240 > 1.0.20-SNAPSHOT-1359033
1.0.10 > 1.0.10
1.0.10-amd64-21736 > 1.0.10
1.0.10-amd64-21736-linux-amd64 > 1.0.10
1.0.10-linux-21736 > 1.0.10
1.0.20-SNAPSHOT-1359033 > 1.0.20-SNAPSHOT-1359033
1.0.20-SNAPSHOT-1359033-amd64-11240 > 1.0.20-SNAPSHOT-1359033';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);