using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^!(\w+):([\w-]+):(\w+)$";
string input = @"!toto120:abc-DEF:tqp34";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}