package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^!(\w+):([\w-]+):(\w+)$`)
var str = `!toto120:abc-DEF:tqp34`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}