using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\w.-]+@(?=[a-z\d][^.]*\.)[a-z\d.-]*[^.]$";
string input = @"adsflkj.-_adsfjadsf@blah.blah.com.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}