$re = '/^[\w.-]+@(?=[a-z\d][^.]*\.)[a-z\d.-]*[^.]$/m';
$str = 'adsflkj.-_adsfjadsf@blah.blah.com.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);