re = /^[\w.-]+@(?=[a-z\d][^.]*\.)[a-z\d.-]*[^.]$/m
str = 'adsflkj.-_adsfjadsf@blah.blah.com.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end