using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\(([0-9])\1{2}\)\1{3}\-\1{4}$)\([0-9]{3}\)[0-9]{3}-[0-9]{4}$";
string input = @"(123)456-7890
(111)111-1111
(999)999-9999";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}