import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\(([0-9])\\1{2}\\)\\1{3}\\-\\1{4}$)\\([0-9]{3}\\)[0-9]{3}-[0-9]{4}$";
final String string = "(123)456-7890\n"
+ "(111)111-1111\n"
+ "(999)999-9999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}