re = /^(?!\(([0-9])\1{2}\)\1{3}\-\1{4}$)\([0-9]{3}\)[0-9]{3}-[0-9]{4}$/m
str = '(123)456-7890
(111)111-1111
(999)999-9999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end