using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(.*[A-Z]){3})(?=(.*[a-z]){3})(?=.*(_|[^\w]))";
string input = @"acAbBC$
AbcBCa%
S4L4S6na#a";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}