$re = '/(?=(.*[A-Z]){3})(?=(.*[a-z]){3})(?=.*(_|[^\w]))/';
$str = 'acAbBC$
AbcBCa%
S4L4S6na#a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);