re = /(?=(.*[A-Z]){3})(?=(.*[a-z]){3})(?=.*(_|[^\w]))/
str = 'acAbBC$
AbcBCa%
S4L4S6na#a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end