import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z\\%\\/\\-\\(\\)\\s]?\\d{3}[a-z\\%\\/\\-\\(\\)\\s]?\\d{3}[a-z\\%\\/\\-\\(\\)\\s]?\\d{4}[a-z\\%\\/\\-\\(\\)\\s]?";
final String string = "(424)525-5455 (424)5424522 555a451%6454 555/444-1211< 5554445552 15424331336 1-524l654-3211 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}