$re = '/[a-z\%\/\-\(\)\s]?\d{3}[a-z\%\/\-\(\)\s]?\d{3}[a-z\%\/\-\(\)\s]?\d{4}[a-z\%\/\-\(\)\s]?/ms';
$str = '(424)525-5455 (424)5424522 555a451%6454 555/444-1211< 5554445552 15424331336 1-524l654-3211 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);