const regex = /[a-z\%\/\-\(\)\s]?\d{3}[a-z\%\/\-\(\)\s]?\d{3}[a-z\%\/\-\(\)\s]?\d{4}[a-z\%\/\-\(\)\s]?/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-z\\%\\\/\\-\\(\\)\\s]?\\d{3}[a-z\\%\\\/\\-\\(\\)\\s]?\\d{3}[a-z\\%\\\/\\-\\(\\)\\s]?\\d{4}[a-z\\%\\\/\\-\\(\\)\\s]?', 'gms')
const str = `(424)525-5455 (424)5424522 555a451%6454 555/444-1211< 5554445552 15424331336 1-524l654-3211 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}