using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^;,`]*(?!`,)|(?:[^`,;]*(?:`,)?))*?";
string input = @"command, arg1, arg2_pt1`,arg2_pt2`,arg2_pt3`,arg2_pt4, arg3_pt1`,arg3_pt2, arg4";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}