const regex = /([^;,`]*(?!`,)|(?:[^`,;]*(?:`,)?))*?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^;,`]*(?!`,)|(?:[^`,;]*(?:`,)?))*?', 'gmi')
const str = `command, arg1, arg2_pt1\`,arg2_pt2\`,arg2_pt3\`,arg2_pt4, arg3_pt1\`,arg3_pt2, arg4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}