$re = '/([^;,`]*(?!`,)|(?:[^`,;]*(?:`,)?))*?/mi';
$str = 'command, arg1, arg2_pt1`,arg2_pt2`,arg2_pt3`,arg2_pt4, arg3_pt1`,arg3_pt2, arg4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);